$re = '/(.*\| .* \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(.*\| .* \| CUSTOM \| Receiver video info \|.*)/m';
$str = '02.03.2025 07:26:47 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert
02.03.2025 07:26:51 | 00000 | CUSTOM | Receiver video info | "!1IFVNo Video,Unknown,,24bit,,Unknown,,24bit,,,"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);