using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Existing Products & Quantity & ID)(.|\n)*(?=CURRENT)";
string input = @"B) For Insert and Modify : Modify Information of Products
(Must check and verify)
Existing Products & Quantity & ID
(1) Jeans 75 J73820
(2) Shirts 10 S02932
(3) Bottoms 2 B0239
*Order ID (Customer Purchase): THK78183XL9102
*Item to check: Stock, Brand
*Before and after:
CURRENT
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 75
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Increase stock
TO BE
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 100
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Add 25 unit";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}