import re
regex = re.compile(r"(?<=Existing Products & Quantity & ID)(.|\n)*(?=CURRENT)", flags=re.MULTILINE)
test_str = ("B) For Insert and Modify : Modify Information of Products\n"
"(Must check and verify)\n"
"Existing Products & Quantity & ID\n"
"(1) Jeans 75 J73820\n"
"(2) Shirts 10 S02932\n"
"(3) Bottoms 2 B0239\n"
"*Order ID (Customer Purchase): THK78183XL9102\n"
"*Item to check: Stock, Brand\n"
"*Before and after:\n\n"
"CURRENT\n\n"
"-----------------------------------------------------------------------------\n"
"Product ID : J73820\n"
"Quantity : 75\n"
"Title : Jeans\n"
"Brand: XXXX\n"
"-----------------------------------------------------------------------------\n"
"NEXT ACTION\n"
"Increase stock\n\n"
"TO BE\n\n"
"-----------------------------------------------------------------------------\n"
"Product ID : J73820\n"
"Quantity : 100\n"
"Title : Jeans\n"
"Brand: XXXX\n"
"-----------------------------------------------------------------------------\n"
"NEXT ACTION\n"
"Add 25 unit")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")