const regex = /(?<=Existing Products & Quantity & ID)(.|\n)*(?=CURRENT)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Existing Products & Quantity & ID)(.|\\n)*(?=CURRENT)', 'gm')
const str = `B) For Insert and Modify : Modify Information of Products
(Must check and verify)
Existing Products & Quantity & ID
(1) Jeans 75 J73820
(2) Shirts 10 S02932
(3) Bottoms 2 B0239
*Order ID (Customer Purchase): THK78183XL9102
*Item to check: Stock, Brand
*Before and after:
CURRENT
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 75
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Increase stock
TO BE
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 100
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Add 25 unit`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}