re = /(?<=Existing Products & Quantity & ID)(.|\n)*(?=CURRENT)/m
str = 'B) For Insert and Modify : Modify Information of Products
(Must check and verify)
Existing Products & Quantity & ID
(1) Jeans 75 J73820
(2) Shirts 10 S02932
(3) Bottoms 2 B0239
*Order ID (Customer Purchase): THK78183XL9102
*Item to check: Stock, Brand
*Before and after:
CURRENT
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 75
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Increase stock
TO BE
-----------------------------------------------------------------------------
Product ID : J73820
Quantity : 100
Title : Jeans
Brand: XXXX
-----------------------------------------------------------------------------
NEXT ACTION
Add 25 unit'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end