using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(a((?1)|-)b)$";
string input = @"a-b
aa-bb
aaaa-bbb
aa-bbbb
aaaaaa-bbb
aaaaaaaaaaa-bbbbbbbbbbb
ab
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}