import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(a((?1)|-)b)$";
final String string = "a-b\n"
+ "aa-bb\n"
+ "aaaa-bbb\n"
+ "aa-bbbb\n"
+ "aaaaaa-bbb\n"
+ "aaaaaaaaaaa-bbbbbbbbbbb\n"
+ "ab\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}