$re = '/^(a((?1)|-)b)$/m';
$str = 'a-b
aa-bb
aaaa-bbb
aa-bbbb
aaaaaa-bbb
aaaaaaaaaaa-bbbbbbbbbbb
ab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);