re = /^(a((?1)|-)b)$/m
str = 'a-b
aa-bb
aaaa-bbb
aa-bbbb
aaaaaa-bbb
aaaaaaaaaaa-bbbbbbbbbbb
ab
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end