#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b.{0,1}(.\.)"
Local $sString = "This is Dr. Mathurs cabin." & @CRLF & _
"aDr. Mathurs cabin." & @CRLF & _
" aaDr. DR. Mathurs cabin." & @CRLF & _
"ABC." & @CRLF & _
"A." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")