using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b.{0,1}(.\.)";
string input = @"This is Dr. Mathurs cabin.
aDr. Mathurs cabin.
aaDr. DR. Mathurs cabin.
ABC.
A.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}