// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b.{0,1}(.\.)").unwrap();
let string = "This is Dr. Mathurs cabin.
aDr. Mathurs cabin.
aaDr. DR. Mathurs cabin.
ABC.
A.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}