$re = '/\b.{0,1}(.\.)/m';
$str = 'This is Dr. Mathurs cabin.
aDr. Mathurs cabin.
aaDr. DR. Mathurs cabin.
ABC.
A.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);