re = /\b.{0,1}(.\.)/m
str = 'This is Dr. Mathurs cabin.
aDr. Mathurs cabin.
aaDr. DR. Mathurs cabin.
ABC.
A.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end