#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^apple\R(?>(?!(?R)).*\R)*?banana\R(?>(?!(?R)).*\R)*?orange$"
Local $sString = "apple" & @CRLF & _
"lemon" & @CRLF & _
"apple" & @CRLF & _
"banana" & @CRLF & _
"apple" & @CRLF & _
"bananabad" & @CRLF & _
"orange" & @CRLF & _
"goood" & @CRLF & _
"banana" & @CRLF & _
"apple" & @CRLF & _
"fun" & @CRLF & _
"banana" & @CRLF & _
"stuff" & @CRLF & _
"more stuff" & @CRLF & _
"orange" & @CRLF & _
"avocado"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")