re = /^apple\R(?>(?!(?R)).*\R)*?banana\R(?>(?!(?R)).*\R)*?orange$/m
str = 'apple
lemon
apple
banana
apple
bananabad
orange
goood
banana
apple
fun
banana
stuff
more stuff
orange
avocado'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end