import re
regex = re.compile(r"^apple\R(?>(?!(?R)).*\R)*?banana\R(?>(?!(?R)).*\R)*?orange$", flags=re.MULTILINE)
test_str = ("apple\n"
"lemon\n"
"apple\n"
"banana\n"
"apple\n"
"bananabad\n"
"orange\n"
"goood\n"
"banana\n"
"apple\n"
"fun\n"
"banana\n"
"stuff\n"
"more stuff\n"
"orange\n"
"avocado")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")