import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^apple\\R(?>(?!(?R)).*\\R)*?banana\\R(?>(?!(?R)).*\\R)*?orange$";
final String string = "apple\n"
+ "lemon\n"
+ "apple\n"
+ "banana\n"
+ "apple\n"
+ "bananabad\n"
+ "orange\n"
+ "goood\n"
+ "banana\n"
+ "apple\n"
+ "fun\n"
+ "banana\n"
+ "stuff\n"
+ "more stuff\n"
+ "orange\n"
+ "avocado";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}