$re = '/^apple\R(?>(?!(?R)).*\R)*?banana\R(?>(?!(?R)).*\R)*?orange$/m';
$str = 'apple
lemon
apple
banana
apple
bananabad
orange
goood
banana
apple
fun
banana
stuff
more stuff
orange
avocado';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);