#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ERROR\s+(?!MO already exist).*$"
Local $sString = "ERROR " & @CRLF & _
"we have an ERROR here da da da " & @CRLF & _
"ERROR Parent MO not found " & @CRLF & _
"ERROR anything else is here " & @CRLF & _
"ERROR MO already exists "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")