using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ERROR\s+(?!MO already exist).*$";
string input = @"ERROR
we have an ERROR here da da da
ERROR Parent MO not found
ERROR anything else is here
ERROR MO already exists ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}