const regex = /ERROR\s+(?!MO already exist).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ERROR\\s+(?!MO already exist).*$', 'gm')
const str = `ERROR
we have an ERROR here da da da
ERROR Parent MO not found
ERROR anything else is here
ERROR MO already exists `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}