import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ERROR\\s+(?!MO already exist).*$";
final String string = "ERROR \n"
+ "we have an ERROR here da da da \n"
+ "ERROR Parent MO not found \n"
+ "ERROR anything else is here \n"
+ "ERROR MO already exists ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}