using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[\w-]\.?)+)@((?:[\w-]+\.)+)([A-Za-z]{2,4})";
string input = @"donkey.kong@kart.com.br
bowser1@games.info
super-mario@nintendo.JP
TEAM.donkey-kong@MARIO.kart1.nintendo.com
toad@kart...com
wario@kart@nintendo.com
yoshi@nintendo
daisy@nintendo.b
..@email.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}