import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[\\w-]\\.?)+)@((?:[\\w-]+\\.)+)([A-Za-z]{2,4})";
final String string = "donkey.kong@kart.com.br\n"
+ "bowser1@games.info \n"
+ "super-mario@nintendo.JP\n"
+ "TEAM.donkey-kong@MARIO.kart1.nintendo.com\n\n"
+ "toad@kart...com\n"
+ "wario@kart@nintendo.com\n"
+ "yoshi@nintendo\n"
+ "daisy@nintendo.b\n"
+ "..@email.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}