import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)^\n"
+ "([\\d-]+)\\s+([\\d:.]+)\\s+\n"
+ "(\\d+)\\s\\s(\\d+)\\s\n"
+ "([VDIWEF])\\s(.*?):\n"
+ "(.*)\n"
+ "$";
final String string = "06-09 17:48:08.555 1644 5345 V EXAPLE_TAG: hello I am a log1\n"
+ "06-09 17:48:08.555 1644 5345 D EXAPLE_TAG: hello I am a log2\n"
+ "06-09 17:48:08.555 1644 5345 I EXAPLE_TAG: hello I am a log3\n"
+ "06-09 17:48:08.555 1644 5345 W EXAPLE_TAG: hello I am a log4\n"
+ "06-09 17:48:08.555 1644 5345 E EXAPLE_TAG: hello I am a log5\n"
+ "06-09 17:48:08.555 1644 5345 F EXAPLE_TAG: hello I am a log6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}