import Foundation
let pattern = #"""
(?x)^
([\d-]+)\s+([\d:.]+)\s+
(\d+)\s\s(\d+)\s
([VDIWEF])\s(.*?):
(.*)
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
06-09 17:48:08.555 1644 5345 V EXAPLE_TAG: hello I am a log1
06-09 17:48:08.555 1644 5345 D EXAPLE_TAG: hello I am a log2
06-09 17:48:08.555 1644 5345 I EXAPLE_TAG: hello I am a log3
06-09 17:48:08.555 1644 5345 W EXAPLE_TAG: hello I am a log4
06-09 17:48:08.555 1644 5345 E EXAPLE_TAG: hello I am a log5
06-09 17:48:08.555 1644 5345 F EXAPLE_TAG: hello I am a log6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)