#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(@\s?)(.*[^(\s\(\d+\))])"
Local $sString = "Title@ First Name Last Name (12)" & @CRLF & _
"Second Title@ First Name Last Name"
Local $sSubst = "$1 $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)