re = /(.*)(@\s?)(.*[^(\s\(\d+\))])/m
str = 'Title@ First Name Last Name (12)
Second Title@ First Name Last Name'
subst = '$1 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result