$re = '/(.*)(@\s?)(.*[^(\s\(\d+\))])/m';
$str = 'Title@ First Name Last Name (12)
Second Title@ First Name Last Name';
$subst = "$1 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;