const regex = /(.*)(@\s?)(.*[^(\s\(\d+\))])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(@\\s?)(.*[^(\\s\\(\\d+\\))])', 'gm')
const str = `Title@ First Name Last Name (12)
Second Title@ First Name Last Name`;
const subst = `$1 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);