import Foundation
let pattern = #"(.*)(@\s?)(.*[^(\s\(\d+\))])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Title@ First Name Last Name (12)
Second Title@ First Name Last Name
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)