using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?";
string substitution = @"$3";
string input = @"Title@ First Name Last Name (12)
Second Title@ First Name Last Name";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}