package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?`)
var str = `Title@ First Name Last Name (12)
Second Title@ First Name Last Name`
var substitution = "$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}