// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?").unwrap();
let string = "Title@ First Name Last Name (12)
Second Title@ First Name Last Name";
let substitution = "$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}