import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(@\\s?)(.*[^(\\s\\(\\d+\\))])(\\s\\(\\d+\\))?";
final String string = "Title@ First Name Last Name (12)\n"
+ "Second Title@ First Name Last Name";
final String subst = "$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}