use strict;
my $str = 'Title@ First Name Last Name (12)
Second Title@ First Name Last Name';
my $regex = qr/(.*)(@\s?)(.*[^(\s\(\d+\))])(\s\(\d+\))?/mp;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";