using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)enteroccocus(.*)";
string substitution = @"";
string input = @" non haemolytic enteroccocus";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}