use strict;
my $str = ' non haemolytic enteroccocus';
my $regex = qr/(.*)enteroccocus(.*)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";