const regex = new RegExp('(.*)enteroccocus(.*)', '')
const str = ` non haemolytic enteroccocus`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);