$re = '/(.*)enteroccocus(.*)/';
$str = ' non haemolytic enteroccocus';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;