import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ghf(?:0[1-9]|[1-4][0-9]|5[012])[0-9]{3}[a-zA-Z]{2}_v[0-9]{2}\\.pdf";
final String string = "ghf50001BE_v02.pdf\n"
+ "ghf53001BE_v02.pdf\n"
+ "ghf01001BE_v02.pdf\n"
+ "ghf52001BE_v02.pdf\n"
+ "ghf13001BE_v02.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}