import re
regex = re.compile(r"ghf(?:0[1-9]|[1-4][0-9]|5[012])[0-9]{3}[a-zA-Z]{2}_v[0-9]{2}\.pdf", flags=re.MULTILINE)
test_str = ("ghf50001BE_v02.pdf\n"
"ghf53001BE_v02.pdf\n"
"ghf01001BE_v02.pdf\n"
"ghf52001BE_v02.pdf\n"
"ghf13001BE_v02.pdf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")