// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ghf(?:0[1-9]|[1-4][0-9]|5[012])[0-9]{3}[a-zA-Z]{2}_v[0-9]{2}\.pdf").unwrap();
let string = "ghf50001BE_v02.pdf
ghf53001BE_v02.pdf
ghf01001BE_v02.pdf
ghf52001BE_v02.pdf
ghf13001BE_v02.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}