const regex = new RegExp('ghf(?:0[1-9]|[1-4][0-9]|5[012])[0-9]{3}[a-zA-Z]{2}_v[0-9]{2}\\.pdf', 'gm')
const str = `ghf50001BE_v02.pdf
ghf53001BE_v02.pdf
ghf01001BE_v02.pdf
ghf52001BE_v02.pdf
ghf13001BE_v02.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}