re = /ghf(?:0[1-9]|[1-4][0-9]|5[012])[0-9]{3}[a-zA-Z]{2}_v[0-9]{2}\.pdf/m
str = 'ghf50001BE_v02.pdf
ghf53001BE_v02.pdf
ghf01001BE_v02.pdf
ghf52001BE_v02.pdf
ghf13001BE_v02.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end