package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}\.\d{2}\.\d{4}-\d{2}\.\d{2}\.\d{4}$`)
var str = `23.04.2019-30.04.2019
3.06.2019-20.06.2019`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}