re = /^\d{1,2}\.\d{2}\.\d{4}-\d{2}\.\d{2}\.\d{4}$/m
str = '23.04.2019-30.04.2019
3.06.2019-20.06.2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end