use strict;
my $str = '23.04.2019-30.04.2019
3.06.2019-20.06.2019';
my $regex = qr/^\d{1,2}\.\d{2}\.\d{4}-\d{2}\.\d{2}\.\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}