#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((((0?[1-9])|([1,2][0-9])|3[0,1])\.((0?[1,3,5,7,8])|10|12))|(((0?[1-9])|([1,2][0-9])|30)\.((0?[2,4,6,9])|11)))\.[0-9]{4}$"
Local $sString = "31.05.2020" & @CRLF & _
"01.01.2020"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")